スレッド:rfriends2_2.7.4.4へUPDATE出来ません。
rfriends2_2.7.4.4へUPDATE出来ません。 投稿者:スガ 投稿日:2021/06/19(Sat) 20:16:49 No.4
Raspberry PiにRfriends2 P 2.6.0z2からrfriends2_2.7.4.4_20210612_script.zipにUPDATEして、sh /home/ruser/rfriends2/rfriends2.shを実行したのですが、エラーが出て起動しません。と、06/15(火)に掲示板に問い合わせところ、

#これはPHPのZIPモジュールがないというエラーです。
#あるいは、環境がなにかおかしいようです。
#もう一度、再インストールしたほうがいいような気がします。
#
#cd ~/
#rm ./all_rfriends2_ubuntu.sh
#wget rfriends.s1009.xrea.com
#      /files/rfriends2_ubuntu.sh
#sh ./rfriends2_ubuntu.sh

とのことでご指示通り再インストールしましたが、以下のエラーが出て実行出来ません、

root@raspberrypi:~# sh /home/pi/rfriends2/rfriends2.sh
PHP Fatal error: Uncaught Error: Class 'ZipArchive' not found in /home/pi/rfriends2/script/rf_common.php:2
Stack trace:
#0 /home/pi/rfriends2/script/rf_inc.php(2): rf_extract('/home/pi/rfrien...', '/home/pi/rfrien...', '')
#1 /home/pi/rfriends2/script/rfriends_check.php(2): require_once('/home/pi/rfrien...')
#2 {main}
thrown in /home/pi/rfriends2/script/rf_common.php on line 2

PHP Fatal error: Uncaught Error: Class 'ZipArchive' not found in /home/pi/rfriends2/script/rf_common.php:2
Stack trace:
#0 /home/pi/rfriends2/script/rf_inc.php(2): rf_extract('/home/pi/rfrien...', '/home/pi/rfrien...', '')
#1 /home/pi/rfriends2/script/rfriends.php(2): require_once('/home/pi/rfrien...')
#2 {main}
thrown in /home/pi/rfriends2/script/rf_common.php on line 2
PHP Fatal error: Uncaught Error: Class 'ZipArchive' not found in /home/pi/rfriends2/script/rf_common.php:2
Stack trace:
#0 /home/pi/rfriends2/script/rf_inc.php(2): rf_extract('/home/pi/rfrien...', '/home/pi/rfrien...', '')
#1 /home/pi/rfriends2/script/rfriends_get_editfn.php(2): require_once('/home/pi/rfrien...')
#2 {main}
thrown in /home/pi/rfriends2/script/rf_common.php on line 2
Re: rfriends2_2.7.4.4へUPDATE 投稿者:rfrends 投稿日:2021/06/20(Sun) 02:22:21 No.6
rfriends2_ubuntu.shは正しくwget できていますか?
sh ./rfriends2_ubuntu.shではどういうメッセージが出ましたか?

旧掲示板ではリンクは正しいのですが、表示が切れています。

cd ~/
rm ./all_rfriends2_ubuntu.sh
wget http://rfriends.s1009.xrea.com/files/rfriends2_ubuntu.sh
sh ./rfriends2_ubuntu.sh
Re^2: rfriends2_2.7.4.4へUPDATE 投稿者:suga 投稿日:2021/06/20(Sun) 09:24:09 No.12
> rfriends2_ubuntu.shは正しくwget できていますか?
> sh ./rfriends2_ubuntu.shではどういうメッセージが出ましたか?
>

wgetは問題なくできました。
sh ./rfriends2_ubuntu.shのシェルも時間はかかりましたが、途中でエラーで落ちることもなく、終了しました。
Re: rfriends2_2.7.4.4へUPDATE 投稿者:rfrends 投稿日:2021/06/20(Sun) 03:21:44 No.7
https://rfriends.hatenablog.com/entry/2021/06/20/031405

「ubuntu/debianにrfriendsをインストールする」を参照してください。
Re^2: rfriends2_2.7.4.4へUPDATE 投稿者:suga 投稿日:2021/06/20(Sun) 09:44:07 No.13
> https://rfriends.hatenablog.com/entry/2021/06/20/031405
>
> 「ubuntu/debianにrfriendsをインストールする」を参照してください。

raspberry pi 3で、OSはRaspbianを使用して2.6.0z2稼働してますが、ubuntu/debianのfriendsを実行しても良いでしょうか。

- WebForum -